Author Topic: 31PA generator/voltage regulator not working.  (Read 41 times)

0 Members and 1 Guest are viewing this topic.

chetbrz

  • Internet Region Group (Paid $$$)
  • Full throttle user!
  • *****
  • Posts: 605
  • 1929 U / 1948 P15
    • Chets Place on the web
Re: 31PA generator/voltage regulator not working.
« Reply #4 on: Yesterday at 08:46:05 PM »

If your PA has a three brush generator see the link below.

http://www.1948plymouth.info/SupportPages/PNWR_Reprint.pdf

Chester Brzostowski -- 1948P15 SpD & 1929 Model U Plymouths - Collector of vehicular lawn ornaments.? http://www.1948Plymouth.info   -   http://www.1929Plymouth.info

32cabrio

  • Full throttle user!
  • *****
  • Posts: 38
Re: 31PA generator/voltage regulator not working.
« Reply #3 on: July 15, 2018, 10:35:28 AM »
A couple of things...
It sounds like the charging system has worked for a while. Consider the fact that the generator and regulator regulator must have a good ground between them to operate properly.
If the regulator has rubber grommets at the attach points to the firewall (I assume that is where you mounted it), it should have a metal strap that goes from one regulator screw attach point to the firewall for a good ground. If not, the hold down screws must have a good contact between the regulator and the firewall to provide the ground. 
Also, the generator must have a good ground.
Clean the attach points where the generator is attached to the block down to bare
metal. Some cars wiring system provides a ground wire from the generator to the regulator.
Bottom line, corrosion may be hampering your grounds and causing your problem.

All voltage regulators that I am familiar with have three lugs on them.
A= Armature
B= Battery
F=field
Not familiar with "L". Has it ever had a wire attached? Could your regulator be solid state?

28 Ply.cpe

  • Full throttle user!
  • *****
  • Posts: 71
Re: 31PA generator/voltage regulator not working.
« Reply #2 on: July 14, 2018, 07:08:24 PM »
I have a 28 ply. I pull the battery out every winter. In the spring I charge it up, put it in and it starts right up and shows charge and drives all summer long. If you go to www.33ply.com/repair/reg It will show you how to check it all out. It is great article.

Lincoln52

  • First Gear
  • ***
  • Posts: 9
31PA generator/voltage regulator not working.
« Reply #1 on: July 12, 2018, 04:25:10 PM »
I have a 6 volt positive ground system. I had the generator rebuilt 2 years ago and had a voltage regulator added to replace the cut out. I remember polarizing the generator/regulator then & it seemed to work ok. Now it doesn't work. I've checked it with a volt/ohm meter. I don't know if it's the generator, regulator or it needs to be polarized again. I removed the battery during the winter. Does it need to be polarized every time the battery is removed? How do you polarize a 6 volt positive ground system?
There are 3 connection tabs on the voltage regulator.
One says F
One says BAT
One says L.  The L has no wires connected to it.
Thanks
-John